Topic: Encryption in a google documents

I do not know if it is a bug, a missing functionality or a strange Google Docs behaviour.
What i want to do is to store a document with google docs and encrypt it. I do that several way (copy and paste from a local Open Office docs or send an email).
Normally when i first open the document, fireGPG works fine and propose to decrypt or visualize the text. Now when i close and re-open the document, the encrypted part has disappeared. If the encrypted part is embedded in a not encrypted part, only the encrypted part disappears.
Strange isn't it ?

Re: Encryption in a google documents

I thought this was a problem with Google's Docs hiding it inside an HTML comment or something but no, it really does just delete the info.

I'm not sure what's happening but it appears to be an all-or-nothing kind of thing: either your document is encrypted or its not.  You can't combine encrypted and unencrypted components or it will mysteriously dump the encrypted part.

The only workaround I can see is to choose "deactivate inline for this site."  Right-click the little icon that looks like a grey-and-white wave to find this option.  When the PGP item is just pure text, it obviously has no problem with that.

Re: Encryption in a google documents

Disappearing messages would worry me, too.
So I did some experimenting just now, trying to replicate the problem BeGe described.

First, a combination of clear text and encryption - saved - closed - opened.
Second, only encryption - also saved - closed - opened.
No problems at all.

Webfork suggested, "deactivate inline for this site", but I didn't do that, because I don't know enough to know where to do it.
So I'm just using plain vanilla FPGP and Google docs.
Why no problems for me, but problems for BeGe and Webfork?

Perhaps the reason it worked smoothly for me is that I used FPGP's text editor.
That works smoothly, but it still doesn't explain the disappearing described in the OP.

-- Peter

Re: Encryption in a google documents

Desactivate inline for the website is the solution.