Topic: gmail decrytion not working

GnuPG and Enigmail work perfectly and encryption and signing works perfectly from gmail with firegpg but when I try to decrypt in gmail using the action button at the bottom of the gmail I get:

FireGPG checked this mail but found no signature or encrypted content

When I highlight the encrypted gmail and use the right click menu to decrypt I get a popup window with these results:

Content-Type: multipart/alternative; boundary="firegpg076eqfwb7vydtjkwg4c54ma1"

Content-Type: text/plain; format=flowed; charset=UTF-8
Content-Transfer-Encoding: base64

Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: base64


If I high light this in the result window and click decrypt I get:

The selection you are trying to import doesn't contain any valid PGP data.

There is a statement towards the bottom of the results window that a valid signature (mine) has been found

Any sugestions? Thank You

Re: gmail decrytion not working

Just discovered that if the incoming is encrypted only, decryption through text selection works.

Re: gmail decrytion not working


Are you using old decryption behaviour ?

Re: gmail decrytion not working

Ive gotten this behaivor before also.  I dont know what causes it.  I just restarted Firefox and it started working again for me, but obviously there is a bug somewhere now that someone else has confirmed this behaivor.

Re: gmail decrytion not working

re: Are you using old decryption behavior ?

No, that box is unchecked. Should I try that? Since the text selection and decryption method works if there is no signature, it must have something to do with dealing with the signature I would guess. The error is solid and the decryption always works if there is no signature as long as I use the text selection method. I do run noscript in Firefox but it is disabled for gmail.
No big panic since I can keep using Thunderbird/Enigmail but it would sure be great to have it work for me in gmail. Thanks for anything you can suggest, and thanks for your efforts to create this terrific addon. It is people like you that make the internet a fun and productive place.

Re: gmail decrytion not working

It's happend only with mails signed & encrypted ?

Re: gmail decrytion not working

Well I just ran one more signed and encrypted test this morning and this time, using the text selection and right click menu decrypt, it decrypted with no problem. So much for my statement that the error was solid. The FireGPG button at the bottom still does not work. I will try to reproduce the problem and let you know if I get anything consistent. Thanks

Re: gmail decrytion not working

It is starting to look like if I generate the email from Thunderbird/Enigmail, then I can decrypt it in gmail/FireGPG, whether it is signed or not. Also signed and encrypted emails produced in gmail/FireGPG that will not decrypt in gmail/FireGPG decrypt just fine in Thunderbird/Enigmail. So it must have something to do with the arguments for decryption that FireGPG is passing to GnuPG since it is obviously the same decryptor being used by both applications.

Re: gmail decrytion not working

Can you send me a sample mail please ?

Re: gmail decrytion not working

I have a similar problem. I get encrypted_only mails from my bank and I'm able to decrypt them via selecting and then context-menu-decrypt, but the button at the bottom of the page (gmail) says that FireGPG could not detect any signed or encrypted text. I haven't tried it with other mail (signed only, signed+encrypted) from other people, because nobody sends me encrypted mail :-(

- Mac OS X 10.6.1
- Firefox 3.5.3
- FireGPG 0.7.9

Edit: I just asked a friend to send me some encrypted mail. Well, FireGPG automatically detected it and asked me about my passphrase, decryption worked well, although the formating of the decrypted mail looks a little strange with lots of ">" and "/" at the wrong place. So it seems to be a problem with those particular encrypted mail from my bank. I could forward an example to a developer if neccessary.

Last edited by kazper (2009-10-01 16:23:37)

Re: gmail decrytion not working

I'm experiencing the exact problem that Arizona originally reported. I have 2 gmail accounts primary and secondary. Secondary forwards to Primary, so I only check primary. I have FireGPG setup to send e-mails for me as secondary. I'm not sure if any of that matters.

I sent an e-mail signed (then tried again encrypted) to my primary account. Since FireGPG sends using my secondary account, it arrives addressed to primary, from secondary, with signature.asc (or encrypted content). In both cases FireGPG reports "no signed or encrypted content found". :-/ I'm in the process of having someone else send me signed or encrypted content.