Topic: Code to ignore escaped URLs in PGP comment


I'm running into an issue with certain web applications, namely vBulletin forums. It seems that for security purposes, some vB forums are setup to automatically escape URL's using brackets. When FireGPG inserts it's URL into the comment, vB picks this up and escaped it with [url ] [/url ] around the URL. This, of course, breaks the FireGPG decryption.

There is an extra space after url because your own forum software here is escaping these as well. :-)


Version: GnuPG v2.0.14 (MingW32)
Comment: Use GnuPG with Firefox : [url ][/url ] (Version: 0.7.10)

###Encrypted Data###

Would there be a way to edit the parser code to ignore and/or correct the escaped URL? I know you can turn off the URL in the comment, but it's difficult to get lots of community members to edit their settings, especially when some of them have to be hand-held through the process of setting encryption up in the first place.

Thanks so much for your consideration!

Re: Code to ignore escaped URLs in PGP comment


Just remove the comment line with url when you're on this forums, this should works tongue


Re: Code to ignore escaped URLs in PGP comment

Yes, that is certainly a solution, but it's cumbersome and tedius for users and it limits the acceptability of your software in these environments. Ours is not the only forum using FireGPG extensively. As more and more web application software parses URLs in order to provide security, this is only going to become more of an issue.

I understand you're busy and probably have more important bugs to squash, but it really would be helpful.

Perhaps I can take a look and possibly contribute some code?