Topic: Not all keys showing up ... ?

I use Enigmail for Thunderbird, but there are times that using GPG in Firefox is helpful too. I have 10 keys that show up in the Enigmail key management interface, but when I attempt to sign/encrypt with FireGPG, only about 5 of the keys are available for use.

What gives?

Re: Not all keys showing up ... ?

Are there subkeys ?

Re: Not all keys showing up ... ?

Only one of the 10 keys has a subkey. (And that one is not showing up.)

Re: Not all keys showing up ... ?

Maybe I can ask a different question ... where exactly does FireGPG look for the public and private keyrings? Is there a specific directory?

Re: Not all keys showing up ... ?

Nope, he simply ask gpg smile

Re: Not all keys showing up ... ?

Alright then something odd is going on here ... because I did the following:

1. Closed Thunderbird (Enigmail) and closed Firefox (FireGPG).
2. Copied 'pubring.gpg' and 'secring.gpg' off to a USB drive, and deleted them from my computer.
3. Opened Thunderbird, and Enigmail's key management tool ... and there was a blank keyring (as expected).
4. Opened Firefox, and the partial keyring of keys STILL SHOWED UP!

So, if FireGPG is pulling from the same keyring as Enigmail, how did it populate the keyring when the keyring files are not even on the computer?

Seems like something is amiss ...

Re: Not all keys showing up ... ?

try a gpg --version in a console, it's will show your home directory that we use smile

Re: Not all keys showing up ... ?

Ah ... yes ... it is looking at a completely different directory than Thunderbird. I need to change that somehow to both point to the same location.

Could that be a feature in a future version? The ability to point to a specific keyring(s)? (This would be good for people trying to use FireGPG as a portable app on a USB drive too!)

Thanks for the help.

Re: Not all keys showing up ... ?

Ok smile

Re: Not all keys showing up ... ?

Nevermind ... figured out how to do it!

1. FireFox --> Tools --> FireGPG --> Options --> GPG tab
2. In the box titled "Add arguments to the gpg command:" insert

        --homedir M:\my\new\directory\gpg

3. Click OK and continue

Now all my keys show up. Hope this helps someone.